Using Your Drupal Web Site
Questions?
Email Amy Alexander: aalexander@nwresd.k12.or.us
With thanks to Paul Nelson for his Drupal expertise
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FOR GENERAL USERS
Anchoring Sections of a Page
Sometimes you may want to put a lot of content on one page. To keep the reader from having to
scroll so much to find what they are looking for, it can be helpful to use anchors. An anchor is a
link within a page that takes you directly to that portion of the page. In essence you are
“bookmarking” part of the page.
For example, let’s say I want to create a page describing the curriculum at my district. I want to
have sections for the math, English, science, and social studies aspects of the curriculum
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You can tell already that this is going to be a very, very long page. To help my readers, I am
going to create anchors to each part of the curriculum. Here is how:
1. Select the text (usually a heading) that you want to point your readers to.

2. Click the little anchor icon in the editing toolbar.
3. The anchor window pops up. Type in the name of the anchor (it’s something only you
will see). Then click Insert.

4. A tiny little anchor symbol appears next to the heading, showing you that the anchor has
been inserted.

5. When you are done creating all your anchors, you need to put links for the anchors at the
top of your page. In my example, I have typed headings for each type of curriculum at
the very top of my page.
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6. Select the link that corresponds to the first anchor. Then click the chain link icon in the
editing toolbar.

7. The Insert/edit link window pops up. Use the Anchors drop-down menu to select the
name of the anchor.

8. Click Insert.
9. Continue these steps for each anchor link.
10. The reader just needs to click on the link at the top of the page, and they will be directed
to that portion of the page.
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Attaching Files
Attaching a file in Drupal is simple, but there are a couple of extra steps you need to take in
order to create a link to a file attachment.
1. While in the Edit tab of your page or story, scroll down to File attachments and click
the little black arrow next to the words, to display the Browse button.

2. Click Browse.
3. A dialog box displays allowing you to search for the file on your computer. Select it and
click Open.
4. You are returned to the File attachments section of Drupal. Click Attach.
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5. The file is now listed in the File attachments section.

Note that beneath the Description box, there is a small URL listed. This is the URL of
the file. If you are planning to create a link to the file from the Body, rather than just
leaving the file at the bottom of the page, copy the URL by highlighting it, then clicking
Control+C.
6. Select the text (you could also select an image) that you would like to become the link to
the file attachment, then click the chain link icon.

Last Updated 02/18/2010

Page 7

7. In the Link URL box, paste the URL of the document, which you copied in Step 5.
Click Insert.

8. Your linked text is now highlighted in blue.

9. You’re almost done! Scroll down to the bottom of the page. Under the File attachments
section, you will see your file listed. Un-check the box that says List by clicking once on
it. This will prevent the file from also being listed at the very bottom of your page. Or,
you can leave the List button checked if you would like the file to show up at the bottom
of the page.
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10. Save your changes.
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Blogging
Some districts use the Drupal blogging feature. The blogging feature is handy because you can
quickly post a series of announcements to your own area of the site, without having to link any
of them up.
To create a blog entry, you must have blogging enabled. Ask your site admin if you are unsure of
your permissions.
1. Click Create content > Blog Entry

2. Enter a title for your blog entry and add content.
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3. You may add pictures, links, and files just as with any other content type. See individual
sections on how to do this.
4. Save.
5. If blogging is enabled, your name is probably linked to your blog somewhere on your
district’s web site – usually in a staff contact page. Click on your name to view your blog.
Or, you can go to My account > View > View recent blog entries

6. If you need to edit your blog, click on the title of an individual post to edit or delete it.
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Creating Events
Events will show up on the web site calendar. There is one calendar for the entire web site.
Different categories of events may be created by NWRESD or by your site admin.
NOTE: Your account must be specifically set up with permission to create events. Ask your site
admin if you are unsure of your permissions.
1. Go to Create content > Event

2. Enter a title for your event. The title will be visible on the calendar.
Also select a category for your event, if categories are available.

Last Updated 02/18/2010

Page 12

3. In the Body section, type additional information if needed. You can insert images and
links, and attach files, just like you can with any other type of content.
Caution: your readers may not realize they need to click the event title to get to the
additional information. You might have to train your readers to do this.

4. Enter the start and end times and dates for your event.

5. There may be optional Signup settings enabled so people can sign up for the event over
the web.
6. At the bottom of the screen, click Save.
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7. Your event will be published to the site-wide events calendar.

Note that the reader can use the top drop-down menu to filter their view of the calendar by a
specific category:
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Creating Links
You can turn text or an image into a link to an email address, a file, another page within the
Drupal site, or an external site. File attachments are covered in the next section, but here’s how
to link to anything besides a file attachment.
1. Select the text or image that you would like to become the link.

2. Click the chain link icon in the editor.
3. In the Link URL box, type or paste the URL to which you want to link.
•
•
•
•

To link to an email address, type mailto: address.
Example: mailto: aalexander@nwresd.k12.or.us
To link to an external site, type or paste the entire URL.
Example: http://www.cnn.com
To link to another page or story within the Drupal site, type ?q=node/node #
Example: ?q=node/270
To link to an anchor, you should have already created the anchor. Use the drop-down
anchor menu to select the appropriate anchor.
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4. NWRESD recommends leaving the Target at the default, Open link in the same
window, unless you’re linking to an external site. In that case you may want to use the
drop-down menu to change the target to Open link in a new window. This way, your
readers won’t have to leave the school/district site to get to the external link.

5. Click Insert.
6. Don’t forget to Submit/Save at the bottom of the page to save this link!
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Creating Pages
You would create a page when:
• You want to create content that does not need to be posted to a category
• You want to capture a lot of information such as long paragraphs of text, many links to
different documents, a staff list, etc.
From any page, you can link to additional pages that you have created.
For example, a classroom teacher might want to have a main page introducing herself and her
class, and then links to separate pages that contain assignments for each class.
1. On the right-hand menu underneath your username, go to Create content > Page.
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2. The page creation form appears. Assign your page a title, but do NOT assign it a topic
from any drop-down menus that may be available; otherwise it will show up on the main
school or district page.

3. In the Body section, type the content you want to appear on your page. Images and links
may be inserted if desired. Files may also be attached. For more information, see pages
18, 26, and 28.
4. Click the Save button at the very bottom of the page. In older versions of Drupal the
button might be called Submit instead of Save.
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5. A screen displays confirming that your page has been created.

6. In the address bar, you will see the node number of the page. That’s the address of the
page. You will need this address if you link to this page from another page or area of the
site.
The format should be:
?q=node/#
Or
/node/# (newer versions – ask NWRESD if you are unsure)
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Creating Page Breaks
Drupal automatically cuts off portions of content that are posted to categories (in order to allow
for more posts to show on one page).
For example, I created a page with the entire prologue from Henry V. When I posted it to the
ABC High School category, here’s what showed up:

The user would have to click Read more to see the full prologue.
You can ensure that all your content shows up immediately, however, by inserting a page break
at the very end of your content.
A page break may be inserted either by clicking the Page Break button in the editing toolbar:

or by clicking disable rich-text and entering the following code:
<!--break-->
Either way, make sure your page break is at the VERY END of all your content.
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When I insert a page break, the reader sees all of my content:
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Deleting Content
To delete content you have created (page, story, blog entry, event), do the following:
1. Once you have navigated to the content, click the Edit tab.

2. Scroll all the way to the bottom of the page. Click the Delete button.

3. A warning appears, asking if you are sure.

4. Click Delete if you are sure, or Cancel if you don’t want to delete your content.
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Editing Content
To edit content you have created (page, story, blog entry, news event), do the following:
1. Navigate to the page, story, or event that you have created.
2. Once you have navigated to the content, click the Edit tab.
Note: If you have posted a story to a category, as in the screen shot below, you will not
immediately see an edit tab. You need to click the title of the individual story/post to get
the edit tab.
For example, I have to click on “Welcome to ABC Middle School.”

Then I can click the Edit tab:
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Make any changes you desire, and then scroll down to the bottom of the screen and hit
Save again.
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Entering SingleSpaced Carriage Returns
By default, when you click Enter at the end of a line, Drupal separates the two lines with a space.
You can single-space text by clicking Shift+Enter at the end of a line.
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Finding Content You Have Created
When you create content, it doesn’t automatically become viewable by the public – you have to
create links to each page or story separately. So, what if you have just created a new page, or a
bunch of pages, and they aren’t linked yet? How do you find them?
1. Go to the block with your username, and beneath it, click My account.

2. Click Track.

3. You will see a list of all the content you have created. Click the title of
any piece of content to find its URL or continue editing it.
Also, if you hover your mouse over the title, its node number will display in the bottom
left hand corner of your browser.
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Inserting an Image
An image can be inserted into any page or story. While in the Body section of a page or story,
do the following:
1. Click the tree icon on the editing toolbar.
2. The insert image dialog box appears. Click the red and white box to the right of Image
URL.

3. Another dialog box appears allowing you to search for the image on your computer.
Click the Upload button.
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4. The screen expands, giving you a Browse button.
5. Click Browse and locate the file on your computer.

6. Once you have located the file, click Open.
7. You are returned to the image upload screen. Click the second Upload button – the one
to the right of the word Browse.
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8. The image will appear in the bottom right corner of the screen, as in the screen shot
above.
9. Click on the picture, or click Send to Editor.

10. You are returned to the original Image Insert window. The link to the image appears in
the Image URL box. Add an optional image description and title. Then click Insert.

Last Updated 02/18/2010

Page 29

11. Once you have inserted the image, you can click once on it so it is outlined with little
white boxes. Click once and hold on any of the edges or white boxes to drag the picture
smaller or larger.
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12. Before inserting the image, you can click the Appearance tab to add a border, border
style, or some space between the picture and surrounding text.

After inserting the image, you can get back to this tab: click on the picture and click the
tree.
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Inserting a Table
1. While in Edit mode, or while creating a new page, click the insert table icon.

2. The Insert/Modify table window pops up.
a. Enter the number of columns for the table.
b. Enter the number of rows.
c. Enter cellpadding and cellpacing in pixels (optional)
d. Fill in alignment, eight, width (optional)
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e. Click the Advanced tab to set a border color, background color, or background
image (optional)

f. Click Insert.
3. The table appears in the body section. Click in any of the cells and start typing to add
your content.

4. To add or delete rows click one of the following buttons:

Add row before
Last Updated 02/18/2010
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Delete row
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5. To add or delete columns click one of the following buttons:

Add column before

Add column after

Delete column

6. To align text at the top of a cell:
a. Click in the cell where the text is misaligned.

b. Click the table cell properties button.
c. Set Vertical alignment to Top.

d. Right above Update you may choose to update all cells in the row or the table, or
to update only the current cell.
e. Click Update.
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Posting a Story
In general, stories are announcements that are posted to categories in Drupal. An example would
be a category called “ABC High School,” where all the news and announcements for ABC High
School get posted to that category and appear in the same part of the web site.
You would post a story if:
• You are a site editor, site admin, or a teacher with special permissions to post stories,
and
• You have an announcement that you want to share with the entire school or district
1. On the right or left-hand navigation menu, underneath your username, go to Create
content > Story
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2. The story submission form appears. Assign your story a title. Select the appropriate
category. In the screen shot below, the Topics drop-down menu is where I select my
category.

3. In the Body field, type the text of your story. Images and links may be inserted if
desired. Files may also be attached.
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4. Click the Save button at the very bottom of the page. In older versions of Drupal the
button might be called Submit instead of Save.

Note: the first time you create content, you will see only two buttons, Save and Preview.
However, when you go back to edit content, you will also see a Delete button.

5. A screen displays confirming that your story has been created.

6. To edit or delete your story, you will need to locate the area of the site where you posted
it. Then click the title of your story.
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“Sticky at Top of Lists”
When you post content to a category, normally the newest story will appear at the top of the
page. However, you can force a story to always appear at the top of a page by making it “sticky
at top of lists.”
When you are creating the page or story, scroll down to Publishing Options and select Sticky at
top of lists.

This ensures that your post will always be at the top of the page. This is useful if posting a
“welcome to our school” type blurb to a category – it makes sense to always have the “welcome”
message at the top of the list of posts.
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Using the Editing Toolbar in the Body Section
There are many tools available that can be used to edit the Body section of a page or story. Here
is a screen shot of what the toolbar looks like, followed by an explanation of what some of the
buttons do. By hovering your mouse over any button, you can also find out what the button
does.
If you do not see all of the following buttons, it is probably because your site editor does not
have them all turned on.

Respectively, these four buttons apply bold, italics, underline, or
strikethrough.
Respectively, these four buttons will align text to the left, the center,
the right, or justified on both sides.

These four drop-downs will
automatically size your text into different header sizes; allow you to select a font type; and allow
you to select a font size. Styles is not currently in use on NWRESD sites.

Respectively, these buttons change font color and highlighting color.
Cut text (scissors), Copy (2 white documents), Paste (clipboard 1), Paste as
Text (clipboard with T), Paste from Word (clipboard with W)
Creates a bulleted list.
Creates a numbered list.
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Respectively, these two buttons “outdent” or “indent” the text. Outdent just means
the text is pushed to the left (like hitting backspace once you have tabbed over). The outdent
button will be grayed out until indentation is applied to the text. You can still use tabbing and
backspacing, however. These buttons are simply a shortcut.
Respectively, these two buttons undo the last action, or redo the last action.
Inserts a link to a file, an email address, another section of the Drupal site, or an external
site. Select the text you want to become the link before you click this button.
Breaks a link. Select the linked text that you want to “un-link” before clicking this button.
Creates an anchor. (see page 70).
Inserts an image.
Cleans up messy code (html)
Inserts a gray horizontal ruler (line) that can be used to separate information on the page.
Removes formatting once text has been selected. Useful if you are copying and pasting
from another source that has fancy text formatting (font size, color, etc.) you don’t want to use.
Allows you to turn on the spellchecker by clicking the button once. The little
downward arrow selects the language for the spellchecker, but the only language right now is
English, so no need to click the arrow. Click the button a second time if you wish to turn off
spellchecker.
Inserts a new table.

Respectively, these two buttons allow you to adjust the properties of the entire
table row, or just the table cell. These buttons will be grayed out unless you are working within
a table. The table cell properties button is very useful because it allows you to adjust the width
and alignment of the table cell, and you can also select background colors for the table.
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Respectively, these three buttons allow you to insert a new table row before
the current row, insert a new table row after the current row, or delete the current row.

Respectively, these three buttons allow you to insert a new table column
before the current column, insert a new table column after the current column, or delete the
current column.
Respectively, these two buttons will split table cells that have been merged, or
merge table cells that have been selected.
This button will insert a page break.
Finally, you may hit disable rich-text or rich-text editor (depends on your version of Drupal) to
view and edit html.
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You can also click the HTML button which displays the html in a separate window.
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Changing Your Password
1. Go to the block with your username, and beneath it, click My account.

2. Click Edit.

3. Change your password by typing it in the Password and Confirm password box.

Don’t forget to scroll all the way to the bottom of the screen, and hit Save when you are
done making changes.
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INSTRUCTIONS FOR SITE ADMINS
Administering Users
Adding Users:
1. Go to Administer > User management > Users
2. Click Add User
3. Fill out username, email address, password.
4. Check off any Roles that may apply to the user.
5. Click Create New Account
Creating New Roles:
You can create custom roles in Drupal to allow specific access to different content types. Note
that since Drupal permissions are role-based, you generally do not assign permissions based on
specific pages of the site. Rather, permissions are assigned based on the ability to edit, delete, or
create certain types of content.
However, if you set someone’s permissions so they can only edit their own content, and then
make them the author of the page (enter their username in the Authoring Information section of a
page), you can give them editing rights to that page, in essence.
To create a new role:
1.
2.
3.
4.
5.

Go to Administer > User management > Roles
Type the role name in the white box next to Add Role.
Click Add Role.
Click edit permissions.
Check boxes for the appropriate permissions you want to give to this role type.

Checking User Permissions:
1. Go to Administer > User management > Permissions.
2. Roles appear at the top of the page. Scroll down to see permissions for all roles.
3. Check or uncheck any boxes relating to any permissions you want to give or take away.
4. Save.
Finding a User’s Blog Number:
A user’s blog number is the same as their user number. In order to link a person’s name (i.e. on a
staff contact page) to their blog, you must know their blog number.
1. Go to Administer > User management > Users
2. Hover your mouse over the person’s username.
3. Their blog number displays in the bottom left corner of the browser window.
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4. Or, click their username. Their user number displays as part of the URL in the address
bar.
5. The address is in the form: user/#. For example, user/3.
6. Link to this number but replace the word user with blog.
For example, for user 3, I would link to:
?q=blog/3
OR
/blog/3 (depends on which link style you are using – ask NWRESD if unsure)
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Creating Blocks
You can add a quick announcement or link to your web site by adding a block. A block is
literally an outlined block that displays on the right or left hand side of your site.
1. Go to Administer > Site Building > Blocks

2. Click Add block.

3. The Add block form displays.
a. Type a Block description in all lowercase letters, no spaces.
b. Type a Block title (what the reader sees).
c. Insert your text in the Block body. If inserting a link you will need to know html.
The format for a link in html is:
<a href=“URL goes here”>Title of link goes here</a>
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4. Scroll down to the very bottom of the screen and click Save Block.

5. Your new block now appears in the block list. You can find it by scrolling down to the
Disabled section and looking for the title.

6. Use the drop-down menu, which defaults to <none>, and select the area where you want
the block to appear.
NOTE: While you are in editing mode, the right sidebar, left sidebar, content, header, and
footer areas will be outlined or highlighted so that you can see where your block will go.
Most people put blocks on the left or right sidebar.
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7. The instant you select a location, the block moves to that list:

8. To save the block in this location, click Save Blocks at the bottom of the screen.

9. You can edit your block anytime by coming back to the list of blocks and clicking
configure next to your block title.

10. You can also control which page(s) or categories your block shows up on. Click
configure and scroll down to Page specific visibility settings.
11. In the white space under Pages, enter the node number or taxonomy/term number where
you want your block to show up.
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12. Save.
13. You can remove a block from visibility anytime by using the first drop-down menu to
change the area from left or right sidebar to <none.>
14. All blocks, except for things like newsfeeds, also have a delete option next to configure.
You can click this word if you wish to delete the block entirely.
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Creating Categories
Sometimes you want to create a section on your web site where multiple stories and pages about
the same topic can be “filed” or posted. For example, a school district might have an athletics
section and they want all athletics-related announcements and pages to always go to this section.
The idea is that many different stories and pages could all go to the same area. This is
accomplished with categories, also called Taxonomy.
1. Go to Administer > Content management > Taxonomy

2. To get started, you need to tell Drupal what overall kinds of categories are available to
users when they post. For example, you might have an athletics section, a music section,
and a drama section that all fall under the general category of “District Announcements.”
District Announcements would be the first category you create. To begin, click Add
vocabulary.

3. Type the Vocabulary name.
The Description is optional, but it is often helpful to describe what this category is used
for.
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Help text is also optional.

4. Under Content types, check off the types of content that are permitted under this
category. For example, you could specify that only pages or stories can be a part of this
category. Select as few or as many content types as you wish. NOTE: If running a
large site where a lot of staff members are posting content, it might be a good idea to
select content types here that most staff members don’t have access to. Otherwise
you may end up with teacher pages accidentally posted to news categories.
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5. Under Settings, check the boxes if you want:
a. Tags – users tag their posts with keywords rather than you, the admin, creating the
categories ahead of time.
b. Multiple select – users can post content to more than one category (useful if you
may have announcements or events that need to appear on multiple areas of the
site)
c. Required – users cannot create one of these content types without posting to a
category
d. Weight – can adjust weight number up or down to control the order in which
vocabularies appear

Finally, click Save.

6. Now you have told Drupal what types of content will be allowed for this “umbrella”
category. But you still have to set up your individual category, such as Middle School
News or Athletics.
Click List,
OR,
If you are not already there, go to Administer > Content management > Taxonomy
You will see a list of all the vocabularies, including the one you have just created.
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7. Click the words add terms next to the name of your vocabulary.

8. Type the Term name (the name of the category, such as Middle School News) and an
optional Description. Click Save.
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9. Once you save, you will be returned to a blank Add Term form, where you can keep
adding categories.

10. When you are done adding terms, click List to view a list of all your categories.
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11. You are now ready for users to begin posting content to these categories.

12. To link to a category you have created, you need to know its address.
Categories/taxonomies in Drupal have the following type of address:
?q=taxonomy/term/#
For example:
?=taxonomy/term/22
Note: you might need to check with NWRESD about addresses as some sites now just
use an extra slash:
/taxonomy/term/22
You will need to create a link to the URL of your category. The link could be within a
page, from a menu button at the top of the site, from within a menu on the left or right
sidebar – it’s up to you.
Need help finding the URL of your taxonomy? Here’s how to find it:
1. Go to Administer > Content management > Taxonomy
2. Click list terms next to the vocabulary you created.

3. Hover your mouse over the name of each term.
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4. The URL displays in your address bar, and also (in Firefox) in the bottom left corner
of your browser.
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Creating Menu Buttons
It is easy to create and delete menu items at the top of the web site. These items appear as
navigation buttons or tabs that the user can click to navigate to certain parts of the site.
Before you can create a new menu item, you must already have a page or category set up for the
menu item you want to add. You must also know the address of this page or category, such as
node/27 or taxonomy/term/3.
1. Go to Administer > Site building > Menus.

2. Click Primary links.

3. Click Add item.

4. In the Path field, type node/# (for static content) or taxonomy/term/# (for a category).
In the Menu link title field, type the name of the button.
The weight drop-down menu controls the placement of the item in the list. Negative
numbers are either highest or, in this case, farthest left. If you leave everything at weight
0, it will fall in alphabetical order.
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Click Save when done making changes.

5. The button now appears near the top of the site.
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6. If you ever want to delete a button completely, you can return to Administer > Site
building > Menus and click on Primary links. Next to each button will be a delete option.
Click delete.

7. You may also click edit if you need to point the link to a different page.
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Creating Menus
Please note that prior to making a menu of links, you need to have created all the pages first.
Any files you want to link to must be uploaded to a “dummy” page so that you can get the URL
of the file.
1. Go to Administer > Site building > Menus

2. Click Add menu.

3. Enter menu information.
a. Type the menu name – it must be all lower case and joined only with hyphens.
b. Enter the Title which is what users will see.
c. The Description is optional, but recommended if you are building a large number
of menus.
d. When you are done, click Save.

Last Updated 02/18/2010

Page 60

4. The name of your menu appears at the top of the screen. Click Add item.
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5. In the Path field, type node/# (for static content) or taxonomy/term/# (for a category).
In the Menu link title field, type the name of the button.
The weight drop-down menu controls the placement of the item in the list. Negative
numbers are either highest or, in this case, farthest left. If you leave everything at weight
0, it will fall in alphabetical order.
Click Save when done making changes.
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6. The new item is listed. Click Add item again to add another link.
You may also use the plus signs to drag items up and down in the menu. If you do this,
you must click Save configuration.

7. If you ever want to come back to your menu to add more items later, go to
Administer > Site building > Menus. Click the title of the menu, then click Add item.
You can also click Edit menu, then Delete if you want to get rid of the menu completely.
8. Finally, to make your menu visible, go to Administer > Site Building > Blocks.
9. Locate your menu in the Disabled list.

10. Move your menu to the desired area of the site using the drop down menu.
11. Click Save Blocks.
12. Click configure and scroll down to Page specific visibility settings to make your menu
visible on only certain pages or areas of the site (see Blocks section for more info).
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